// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r">\s*\n\s*(\w.*\w)\s*\n\s*<").unwrap();
let string = "<input>
<program_name>
CS
</program_name>
<course_name>
ART CLASS
</course_name>
<instructor>
John Smith
</instructor>
</input>";
let substitution = ">\\1<";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}