$re = '/\bhref="(?:[^"]*)topic\/(\d+)-.*">$/m';
$str = 'href="http://google.com/topic/713725-dogs-are-great-3">
href="http://google.com/topic/213225-humans-are-great">
href="http://google.com/topic/342315-cats-are-great-but-small">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);