re = /\bhref="(?:[^"]*)topic\/(\d+)-.*">$/m
str = 'href="http://google.com/topic/713725-dogs-are-great-3">
href="http://google.com/topic/213225-humans-are-great">
href="http://google.com/topic/342315-cats-are-great-but-small">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end