#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mU)<(\w+) [^<>]*\bclass\s*=\s*"[^"]*\bmd\b[^"]*"[^<>]*>[^<>]+<\/\1>"
Local $sString = "<b sdsd md sdsdds>a</b> " & @CRLF & _
"<b>adsa</b>" & @CRLF & _
"<b md>a</b>" & @CRLF & _
"<b md>sdasdas</b>" & @CRLF & _
"<b md class ="sd">aaa</b> <b md>aaa</b> <b md>a</b>" & @CRLF & _
"<b ac md>a</b>**DENEME** **DENEME**" & @CRLF & _
"" & @CRLF & _
"<b md>sd <b md>sd</b></b>" & @CRLF & _
"" & @CRLF & _
"<b md>(boş olmasın)</b>" & @CRLF & _
"<b md class ="md" id="1">aaa</b> <b md>aaa</b> <b md>a</b>" & @CRLF & _
"<b md class ="test sd md test">aaa</b> <b md>aaa</b> <b md>a</b>" & @CRLF & _
"" & @CRLF & _
"<b class="...blah md blah...">(expression)</b>" & @CRLF & _
"" & @CRLF & _
"<b class="... md ..."></b> not match because tag is empty" & @CRLF & _
"<i class="..."></i> not match because class attribute not include md" & @CRLF & _
"<span class="...md...">ANYTHING</span> match" & @CRLF & _
"<b class="... md ..."> </b>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")