import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!^)(?<!\\t)\\t+";
final String string = " BBHH Balanço Patrimonial\n"
+ " 1. ATIVO Assets\n"
+ " 1.1 CIRCULANTE\n"
+ " 1.2 NÃO CIRCULANTE\n"
+ " 2. PASSIVO Liabilities and Equity\n"
+ " 3. RECEITAS\n"
+ " 4. CUSTOS E DESPESAS\n"
+ " 4.1 CUSTOS DE PRODUTOS VENDIDOS E SERVIÇOS\n"
+ " 4.1.1 CUSTOS DE PRODUTOS VENDIDOS\n"
+ " 4.1.1.1 CUSTOS DE PRODUTOS VENDIDOS\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}