use strict;
my $str = ' BBHH Balanço Patrimonial
1. ATIVO Assets
1.1 CIRCULANTE
1.2 NÃO CIRCULANTE
2. PASSIVO Liabilities and Equity
3. RECEITAS
4. CUSTOS E DESPESAS
4.1 CUSTOS DE PRODUTOS VENDIDOS E SERVIÇOS
4.1.1 CUSTOS DE PRODUTOS VENDIDOS
4.1.1.1 CUSTOS DE PRODUTOS VENDIDOS
';
my $regex = qr/(?<!^)(?<!\t)\t+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}