# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!^)(?<!\t)\t+"
test_str = (" BBHH Balanço Patrimonial\n"
" 1. ATIVO Assets\n"
" 1.1 CIRCULANTE\n"
" 1.2 NÃO CIRCULANTE\n"
" 2. PASSIVO Liabilities and Equity\n"
" 3. RECEITAS\n"
" 4. CUSTOS E DESPESAS\n"
" 4.1 CUSTOS DE PRODUTOS VENDIDOS E SERVIÇOS\n"
" 4.1.1 CUSTOS DE PRODUTOS VENDIDOS\n"
" 4.1.1.1 CUSTOS DE PRODUTOS VENDIDOS\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.