use strict;
my $str = '{"log":"a_level=\\"INFO\\", a_time=\\"2021-09-17 07:33:35,210\\", a_msg=\\"CommissionRouteType: Client / clientId: 111/ planId: 111 / PolicyBusinessId: 111\\","level":"info"}';
my $regex = qr/\b(a_msg)\b[^\"]+\"(?<a_msg>[^\"]*)\"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}