#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(?:[_-][^\W_]+)*@(?![\d._-]+\.[^\W_]+$)[^\W_]+(?:[_-][^\W_]+)*\.[^\W_]{2,3}$"
Local $sString = "xxx@_domain.com" & @CRLF & _
"xxx@domain_.com" & @CRLF & _
"xxx@-domain.com" & @CRLF & _
"xxx@domain-.com" & @CRLF & _
"-xxx@domain.in" & @CRLF & _
"xxx@111.com" & @CRLF & _
"xxx@1and1.com" & @CRLF & _
"xxx@us.com" & @CRLF & _
"xxx@my-india.com" & @CRLF & _
"xxx@me2.com" & @CRLF & _
"xxx@tv.com" & @CRLF & _
"xxx@abc_efg.com" & @CRLF & _
"_muth@tamil.com" & @CRLF & _
"xx-u@my-india.commmmm" & @CRLF & _
"x-xx@1and1.com" & @CRLF & _
"" & @CRLF & _
"xxx@_domain.com => invalid @ starts with _" & @CRLF & _
"xxx@domain_.com => invalid domain ends with _ " & @CRLF & _
"xxx@-domain.com => invalid @ starts with - ( hypen)" & @CRLF & _
"xxx@domain-.com => invlaid domain ends with - (hypen)" & @CRLF & _
"-xxx@domain.in => invalid domain start with - (hypen)" & @CRLF & _
"xxx@111.com => invalid domain only contains numbers" & @CRLF & _
"xxx@1and1.com => valid domain contains both number and chars" & @CRLF & _
"xxx@us.com => valid" & @CRLF & _
"xxx@my-india.com => valid" & @CRLF & _
"xxx@me2.com => valid" & @CRLF & _
"xxx@tv.com =>" & @CRLF & _
"xxx@abc_efg.com => valid _ inside the chars" & @CRLF & _
"_muth@tamil.com => valid _ start with "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")