Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
`
[^@]{2,64}@[^.]{2,253}\.[0-9a-z-.]{2,63}
`
Input 1
1
New
name@anywhere.something