package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{2}(\d{2})?\/\d{2}\/\d{2}(\d{2})?)|(\d{2}:\d{2}(:\d{2})?)`)
var str = `----------17/01/01----------00:00:00-----
-----17/02/02 09:03----------------------
--------------------34:23----------------
-----17/02/04 11:09:24-------------------
------------------17/04/27---------------
-----------------------------------------
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}