import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}(\\d{2})?\\/\\d{2}\\/\\d{2}(\\d{2})?)|(\\d{2}:\\d{2}(:\\d{2})?)";
final String string = "----------17/01/01----------00:00:00-----\n"
+ "-----17/02/02 09:03----------------------\n"
+ "--------------------34:23----------------\n"
+ "-----17/02/04 11:09:24-------------------\n"
+ "------------------17/04/27---------------\n"
+ "-----------------------------------------\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}