// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{2}(\d{2})?\/\d{2}\/\d{2}(\d{2})?)|(\d{2}:\d{2}(:\d{2})?)").unwrap();
let string = "----------17/01/01----------00:00:00-----
-----17/02/02 09:03----------------------
--------------------34:23----------------
-----17/02/04 11:09:24-------------------
------------------17/04/27---------------
-----------------------------------------
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}