$re = '/value="\K\d+(?=")/';
$str = '<option value="123"></option>
<option value="412"></option> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);