re = /(?<=:)(?=:)|(?<= )(?=:)|(?<=:)(?= )/m
str = 'Hello, :smile::hearth: world!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end