#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.+\n)*.*?\bcat\b.*(?:\n.+)*"
Local $sString = "Paragraph 1 wepfowfpo" & @CRLF & _
"fww efwf" & @CRLF & _
"" & @CRLF & _
"Paragraph 2 wefwf32321" & @CRLF & _
"!@d r33tcat54, 333!.." & @CRLF & _
"" & @CRLF & _
"Paragraph 3 4t4t022" & @CRLF & _
"-`121231ere3r3cat342232" & @CRLF & _
"$ 4t0g cat rdwd203 " & @CRLF & _
"$$333" & @CRLF & _
"" & @CRLF & _
"Paragraph 4 222cocdo3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")