re = /^(?:.+\n)*.*?\bcat\b.*(?:\n.+)*/m
str = 'Paragraph 1 wepfowfpo
fww efwf
Paragraph 2 wefwf32321
!@d r33tcat54, 333!..
Paragraph 3 4t4t022
-`121231ere3r3cat342232
$ 4t0g cat rdwd203
$$333
Paragraph 4 222cocdo3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end