use strict;
my $str = 'va1, var2, aVar,var4, my_var55 DECIMAL(20,4),';
my $regex = qr/(?<=\S),(?=\h*\b[^\W\d])/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";