# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\"\$basetexture\".*)/\1\n\t"$basetexturetransform" "center .5 .5 scale 4 4 rotate 0 translate 0 0"/gm;t' <<< "\"LightmappedGeneric\"
{
\"$basetexture\" \"Concrete/concrete_modular_floor001a\"
\"$surfaceprop\" \"concrete\"
\"%keywords\" \"portal\"
}
\"LightmappedGeneric\"
{
\"$nobasetexture\" \"Concrete/concrete_modular_floor001a\"
\"$surfaceprop\" \"concrete\"
\"%keywords\" \"portal\"
}"