use strict;
my $str = '"LightmappedGeneric"
{
"$basetexture" "Concrete/concrete_modular_floor001a"
"$surfaceprop" "concrete"
"%keywords" "portal"
}
"LightmappedGeneric"
{
"$nobasetexture" "Concrete/concrete_modular_floor001a"
"$surfaceprop" "concrete"
"%keywords" "portal"
}';
my $regex = qr/(\"\$basetexture\".*)/mp;
my $subst = '\\1\\n\\t"$basetexturetransform" "center .5 .5 scale 4 4 rotate 0 translate 0 0"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";