$re = '/(\"\$basetexture\".*)/m';
$str = '"LightmappedGeneric"
{
"$basetexture" "Concrete/concrete_modular_floor001a"
"$surfaceprop" "concrete"
"%keywords" "portal"
}
"LightmappedGeneric"
{
"$nobasetexture" "Concrete/concrete_modular_floor001a"
"$surfaceprop" "concrete"
"%keywords" "portal"
}';
$subst = "\1\n\t\"$basetexturetransform\" \"center .5 .5 scale 4 4 rotate 0 translate 0 0\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;