# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\"\$basetexture\".*)"
test_str = ("\"LightmappedGeneric\"\n"
"{\n"
" \"$basetexture\" \"Concrete/concrete_modular_floor001a\"\n"
" \"$surfaceprop\" \"concrete\"\n"
" \"%keywords\" \"portal\"\n"
"}\n"
"\"LightmappedGeneric\"\n"
"{\n"
" \"$nobasetexture\" \"Concrete/concrete_modular_floor001a\"\n"
" \"$surfaceprop\" \"concrete\"\n"
" \"%keywords\" \"portal\"\n"
"}")
subst = "\\1\\n\\t\"$basetexturetransform\" \"center .5 .5 scale 4 4 rotate 0 translate 0 0\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.