import Foundation
let pattern = #"(\"\$basetexture\".*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"LightmappedGeneric"
{
"$basetexture" "Concrete/concrete_modular_floor001a"
"$surfaceprop" "concrete"
"%keywords" "portal"
}
"LightmappedGeneric"
{
"$nobasetexture" "Concrete/concrete_modular_floor001a"
"$surfaceprop" "concrete"
"%keywords" "portal"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\n\t"$basetexturetransform" "center .5 .5 scale 4 4 rotate 0 translate 0 0""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)