package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((?<path>\\.+)\\(?<file>[^\.]+)\.(?<ext>[^\)]+)\)`)
var str = `(\Device\HarddiskVolume1\Windows\explorer.exe) attempted to load \Device\HarddiskVolume1\Users\vagrant\Downloads\kitty-0.74.4.6.exe `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}