// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\((?<path>\\.+)\\(?<file>[^\.]+)\.(?<ext>[^\)]+)\)").unwrap();
let string = "(\\Device\\HarddiskVolume1\\Windows\\explorer.exe) attempted to load \\Device\\HarddiskVolume1\\Users\\vagrant\\Downloads\\kitty-0.74.4.6.exe ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}