using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[)|(\])";
string substitution = @"";
string input = @"[doing, wing, ingot]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}