$re = '/(?:\[)|(\])/';
$str = '[doing, wing, ingot]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;