import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)-Nr(\\d+)-(\\d+,?\\d*)x(\\d+,?\\d*)cm-(.*)(\\d{4}\\b)-?(\\d+)?(.*)?";
final String string = "G22-Nr035-100x150cm-Backlight-2020\n\n"
+ "HOLLU-Nr357-33,5x500cm-Backlight-nicht-hinterleuchtet-2021\n\n"
+ "GRIBA-Nr651-200x300cm-Blockout-2018\n\n"
+ "GRAMM-Nr470-200x100cm-Backlight-nicht-hinterleuchtet-2021-4Stk\n\n"
+ "HAGELSCHUTZ-Nr1082-150x400cm-Backlight-nicht-hinterleuchtet-mit Schlaufe-2021";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}