$re = '/ ([a-z]\)) /m';
$str = 'a) ciao bau miao b) viva gianni c) ciro dorme';
$subst = "\n$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;