// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)<p[^>]*>(.+?)<\/p>").unwrap();
let string = "<p style=\"text-align: center;\">It is a long established fact that a reader will be distracted by the readable content of a page when looking at its layout</p>
<p style=\"text-align: center;\">It is a long established fact that a reader will be
distracted by the readable <br />
content of a page when looking at its layou</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}