#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?Name:\s*(.*?)(?=\s*(?:Name:|Address:|City:|$))"
Local $sString = "Name: John Doe Address: Street 123 ABC " & @CRLF & _
"Name: John Doe Address: Street 123 ABC City: MyCity" & @CRLF & _
"Name: John Doe City: MyCity Address: Street 123 ABC " & @CRLF & _
"Some other textName: John Doe Address: Street 123 ABC City: MyCity" & @CRLF & _
"Name: John Doe Address: Street 123 ABC City: MyCity Address: Second address" & @CRLF & _
"Name: John DoeAddress: Street 123 ABC"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")