using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?Name:\s*(.*?)(?=\s*(?:Name:|Address:|City:|$))";
string input = @"Name: John Doe Address: Street 123 ABC
Name: John Doe Address: Street 123 ABC City: MyCity
Name: John Doe City: MyCity Address: Street 123 ABC
Some other textName: John Doe Address: Street 123 ABC City: MyCity
Name: John Doe Address: Street 123 ABC City: MyCity Address: Second address
Name: John DoeAddress: Street 123 ABC";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}