import Foundation
let pattern = #"^.*?City:\s*(.*?)(?=\s*(?:Name:|Address:|City:|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Name: John Doe Address: Street 123 ABC
Name: John Doe Address: Street 123 ABC City: MyCity
Name: John Doe City: MyCity Address: Street 123 ABC
Some other textName: John Doe Address: Street 123 ABC City: MyCity
Name: John Doe Address: Street 123 ABC City: MyCity Address: Second address
Name: John DoeAddress: Street 123 ABC
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)