import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S+(?:[ ]{1,49}\\S+)*";
final String string = "All: Day and Night Vulnerabilities\\\\Personnel vulnerabilities\\\\Outdoor vulnerability 1E-09 /AvgeYear \\x1a'\n\n"
+ "All: Day and Night\n"
+ "All: Day and Night";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}