// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S+(?:[ ]{1,49}\S+)*").unwrap();
let string = "All: Day and Night Vulnerabilities\\\\Personnel vulnerabilities\\\\Outdoor vulnerability 1E-09 /AvgeYear \\x1a'
All: Day and Night
All: Day and Night";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}