using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""customer_id"":""([^""]+)""";
string input = @"{""param"":""success"",""value"":""10"",""level"":""0"",""error_code"":""101"",""customer_id"":""5b0e9b23e423b0d33c9f7ddfd"", ""purchases"": ""13"", ""last_activity_ts"": ""123523465""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}