// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"customer_id":"([^"]+)""#).unwrap();
let string = "{\"param\":\"success\",\"value\":\"10\",\"level\":\"0\",\"error_code\":\"101\",\"customer_id\":\"5b0e9b23e423b0d33c9f7ddfd\", \"purchases\": \"13\", \"last_activity_ts\": \"123523465\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}