# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\|move\|p([12])a:\s+([^|]+)\|([^|]+)"
test_str = ("|move|p2a: Urshifu|Wicked Blow|p1a: Clefable\n"
"|move|p1a: Clefable|Stealth Rock|p2a: Jirachi\n"
"|move|p2a: Jirachi|Stealth Rock|p1a: Slowbro\n"
"|move|p2a: Jirachi|U-turn|p1a: Slowbro\n"
"|move|p1a: Slowbro|Teleport|p1a: Slowbro\n"
"|move|p1a: Dragapult|Shadow Ball|p2a: Starmie\n"
"|move|p2a: Togekiss|Air Slash|p1a: Excadrill|[miss]\n"
"|move|p1a: Excadrill|Rapid Spin|p2a: Amoonguss\n"
"|move|p2a: Amoonguss|Spore|p1a: Tangrowth\n"
"|move|p1a: Tangrowth|Knock Off|p2a: Amoonguss\n"
"|move|p2a: Amoonguss|Sludge Bomb|p1a: Tangrowth\n"
"|move|p2a: Amoonguss|Spore|p1a: Excadrill\n"
"|move|p2a: Togekiss|Flamethrower|p1a: Excadrill\n"
"|move|p1a: Excadrill|Iron Head|p2a: Togekiss\n"
"|move|p2a: Cinderace|Pyro Ball|p1a: Slowbro\n"
"|move|p2a: Cinderace|U-turn|p1a: Slowbro\n"
"|move|p1a: Slowbro|Teleport|p1a: Slowbro\n"
"|move|p2a: Urshifu|U-turn|p1a: Clefable\n"
"|move|p1a: Clefable|Thunder Wave|p2a: Cinderace\n"
"|move|p2a: Cinderace|Pyro Ball|p1a: Slowbro\n"
"|move|p1a: Slowbro|Slack Off|p1a: Slowbro\n"
"|move|p2a: Cinderace|U-turn|p1a: Slowbro\n"
"|move|p1a: Slowbro|Teleport|p1a: Slowbro\n"
"|move|p1a: Crawdaunt|Crunch|p2a: Amoonguss\n"
"|move|p2a: Amoonguss|Giga Drain|p1a: Crawdaunt\n"
"|move|p1a: Crawdaunt|Crunch|p2a: Cinderace\n"
"|move|p2a: Urshifu|U-turn|p1a: Tangrowth\n"
"|move|p1a: Tangrowth|Earthquake|p2a: Amoonguss\n"
"|move|p2a: Amoonguss|Spore|p1a: Tangrowth\n"
"|move|p1a: Tangrowth|Earthquake|p2a: Amoonguss\n"
"|move|p2a: Amoonguss|Spore|p1a: Tangrowth\n"
"|move|p1a: Excadrill|Earthquake|p2a: Amoonguss\n"
"|move|p1a: Excadrill|Earthquake|p2a: Jirachi\n"
"|move|p2a: Urshifu|Wicked Blow|p1a: Excadrill\n"
"|move|p2a: Urshifu|Wicked Blow|p1a: Slowbro\n"
"|move|p2a: Urshifu|Wicked Blow|p1a: Clefable\n"
"|move|p1a: Clefable|Moonblast|p2a: Urshifu")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.