// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^,()\s][^,\n]*)\s\(").unwrap();
let string = "Topic 1 (Speaker 1)
Event_type_1 - , Topic 2 (Speaker 2)
Event_type_2 - , Topic 3 (Speaker 3)
Topic 4 (subtopic 1) (Speaker 1)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}