#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\w:\\|\\{1,2})((\.{2}\\)+|(\.+\\)?).+"
Local $sString = "..\meeting_minutes.txt" & @CRLF & _
"..\..\profile.txt" & @CRLF & _
"Reports\2023\summary.txt" & @CRLF & _
"\Reports\2023\summary.txt" & @CRLF & _
"C:\my_file.txt" & @CRLF & _
"\\Reports\2023\summary.txt" & @CRLF & _
".\Reports\2023\summary.txt" & @CRLF & _
"..\Projects\project_a.docx" & @CRLF & _
"..\Projects\project a.docx" & @CRLF & _
".\my_file.txt" & @CRLF & _
".\my file.txt" & @CRLF & _
"..\..\data" & @CRLF & _
"..\Music#a\file.mp3" & @CRLF & _
"..\Music[Genre]\file.mp3" & @CRLF & _
"..\Music(Genre)\file.mp3" & @CRLF & _
"..\Music-Hardcore-Metal\file.mp3" & @CRLF & _
"..\Documents\My+File.xlsx" & @CRLF & _
"..\Documents\Some{Document}.py" & @CRLF & _
"..\Files\Afilewithweird;Characters'`.doc" & @CRLF & _
"..\Music#^@!()-+{};',.`~a\file.mp3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")