# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<mem_type> \d{4}/\d{4}/\d{4}\s/\d{4})|(certain\s(?P<mem_quality>\w+))"
test_str = ("<Total Slots :>\n"
" <8 (4-channel per CPU, 8 DIMM per CPU)>\n"
" <Capacity :>\n"
" <Maximum up to 1024GB RDIMM>\n"
" <Memory Type :>\n"
" <fd4 2933/2666/2400 /2133 RDIMM\n"
" bbh567 2933/2666/2400 /2133 LRDIMM>\n"
" <screen :>\n"
" <720>\n"
" <color :>\n"
" <blue>\n"
" <Memory Quality :>\n"
" <Certain 3452345tte READ\n"
" Non certain 7JJEN232 LREAD>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.