$re = '/([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}(\-[a-zA-Z]{1,50})?)/m';
$str = 'Should match
0.0.0
0.0.0-a
1.5.89-lorem
6.12.5-iPsUm
Mustn\'t match (even partially)
a.2.3 -> \'a\' is not a number
1.5.89:lorem -> only \'-\' is valid to separate version and letters
1.2.3-4 -> \'4\' is not letter(s)
5.6.8.9 -> \'9\' is not letters and \'.\' used instead of \'-\'
8.k.2-j -> \'k\' is not a number
7895.5.8 -> \'7895\' is 4 digit long, 3 is the max
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);