use strict;
my $str = 'let str = \'https://www.google.com.ua/images/branding/product/ico/googleg_lodp.ico\'
let str1 = \'https://www.google.com/images/branding/product/ico/googleg_lodp.ico\'
let str2 = \'https://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico\'
http://test.google.com/test.google.com/
http://a.b.c.d.test.google.com/test.google.com/';
my $regex = qr/https?.*?(\w{4,})(?=(?:\.\w{2,3})+\/)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}