Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
[[:blank:]]*+(?:[\[\(].*[\]\)][[:blank:]]*+)?(.*?)[[:blank:]\[\(]*+([1-2]\d{3}).*
/
gmx
Input 1
1
New
2 Fast 2 Furious [2003] [SD] 2 Fast 2 Furious (2003) [SD] 2 Fast 2 Furious ((2003) [SD] A Goofy Movie (1995) (HD) (720p) [test]A Goofy Movie (1995) (HD) (720p) (test) A Goofy Movie (1995) (HD) (720p) 2 Fast 2 Furious 2003 2 Fast 2 Furious 2003 The Lion King 2- Simba's Pride (1998) (HD) (1080p) The.Grand.Budapest.Hotel.2014.1080p.BluRay.x264-BLOW Another.Earth.2011.LIMITED.720p.BluRay.X264-AMIABLE The.Green.Mile.1999.720p.BluRay.x264-HDCLASSiCS The Road 2009 Bluray DTS 720 p - TRiNiTY Dead Poets Society (1989) 720p Blu-ray x264 DTS MSubs [DDR] Garden.State.2004.720p.BluRay.X264-AMIABLE
Substitution
\1 (\2) \3