$re = '/([\d.]+)\s?(\D{0,2})\s?x\s?([\d.]+)\s?\2?|(\d+)/mi';
$str = 'Canvas 36.5 X 48 piece-10
wallpaper 3"X27"
Banner 49x87 -10
14 Vinyl 38 x 9.7
wallpaper 3ftX2Ft PC-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);