$re = '/^(?!\+37|0037)\+?\d+$/m';
$str = '+34999888112
0085999345534
003799912345
+37894888112';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);