using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^\d.\n])\d*\.\d+\b(?!\.\d)";
string input = @"= INT
123
+333
-5
= FLOAT
1334.455
.323
-323.323
+.2
-.34";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}