re = /(^|[^\d.\n])\d*\.\d+\b(?!\.\d)/m
str = '= INT
123
+333
-5
= FLOAT
1334.455
.323
-323.323
+.2
-.34'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end