$re = '/ +--> +([a-zA-Z_\/.-]+):(\d+):(\d+)::::(.*)/m';
$str = ' --> src/blah.rs:55:32::::error: expected one of `,`, `.`, `?`, `}`, or an operator, found `;`
|
55 | 4u8 => unimplemented!(); 42,
| -- ^ expected one of `,`, `.`, `?`, `}`, or an operator here
| |
| while parsing the `match` arm starting here
--> src/foobar.rs:4:1::::error[E0072]: recursive type `foo::Bar` has infinite size
|
| errors are bad, mkay?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);