package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ixm)^(?:(http?|s?ftp):\/\/|file:\/\/\/)?(([\P{Cc}]+):([\P{Cc}]+)@)?([a-zA-Z0-9][a-zA-Z0-9.-]*)(:[0-9]{1,5})?($|\/[\w\-\._~:\/?[\]@!\$&'\(\)\*\+,;=.]+(\#[\w]*)?$)`)
var str = `sftp://monitoring.fre31/nagios/cgi-bin/status.cgi?hostgroup=fezgz&style=detail
file:///opt/myfile.tar.gz
https://test:ho@mydomain/video.mp4
https://test:ho@mydomain.frho.fr/fhi/subdir/download#jfpze`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}